Things to note when installing Service Pack 1 for SharePoint 2010

Here are a few things to watch out for that I have seen create some major issues when installing Service Pack 1 for SharePoint 2010.

1. Make sure you have all the Service Pack 1 updates you need

When installing Service Pack 1 you need to make sure you have all the right Service Pack 1 upgrades. Unfortunately, Language Packs are all individual and there is a Foundation and a Server for each one.

2. List of the SharePoint 2010 SP1 downloads:

3. Stop the User Profile synchronization service

There have been a lot of issues when installing service pack 1 related to the user profile service. Stop any running synchronizations and stop the user profile synchronization this will help to avoid these errors from happening.

4. Restart your Servers

Make sure that you restart your servers after installing all of the foundation updates and then again after installing the server updates. If you do not restart you servers you can run it to some challenging issues.

5. Cache issues

Sometimes after installing a service pack to a server you will run the configuration wizard and it will give you an error that the service pack is not installed on the server. This issue will persist even after hitting the refresh button on the configuration wizard. To resolve this issue run the powershell command below from the SharePoint Management Console. This will reset the cache file that the configuration wizard is looking to.


6. The Configuration Wizard Fails

There is a good chance when you are doing the SP1 upgrade that the Configuration Wizard will fail on one of your servers. If it does run the psconfig.exe command (from the 14 hive bin folder) shown below:

.\psconfig.exe –cmd upgrade –inplace b2b –force -wait